Skip to content

Amazon RDS for PostgreSQL supports new minor version 14.4

Amazon Relational Database Service (Amazon RDS) for PostgreSQL now supports PostgreSQL minor version 14.4. We recommend you upgrade to this latest minor version to fix known security vulnerabilities and bugs from prior versions of PostgreSQL. Please refer to the PostgreSQL community announcement for more details about the release.

Source:: Amazon AWS