Skip to content

Amazon EKS and Amazon EKS Distro now support Kubernetes version 1.23

You can now use Amazon EKS and Amazon EKS Distro to run Kubernetes version 1.23. Highlights of Kubernetes version 1.23 release include graduation of PodSecurity and Ephemeral containers to beta, and graduation of HorizontalPodAutoscaler to GA. Additionally, Kubernetes version 1.23 turns on CSI migration feature for Amazon EBS by default. You can find more details about Kubernetes 1.23 release in the EKS blog post, EKS release notes, and in the Kubernetes project release notes. Support for version 1.23 will be available in Amazon EKS Anywhere in the next couple of weeks.

Source:: Amazon AWS