Skip to content

Vulnerability in Spring Framework Affecting Cisco Products: March 2022

On March 31, 2022, the following critical vulnerability in the Spring Framework affecting Spring MVC and Spring WebFlux applications running on JDK 9+ was released: 

    CVE-2022-22965: Spring Framework RCE via Data Binding on JDK 9+

For a description of this vulnerability, see VMware Spring Framework Security Vulnerability Report.

This advisory will be updated as additional information becomes available.

This advisory is available at the following link:
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-java-spring-rce-Zx9GUc67

Security Impact Rating: Critical

CVE: CVE-2022-22965

Source:: Cisco Security Advisories