AWS [email protected] now supports Node 14.x

Starting today, you can now use the Node.js 14.x runtime to develop functions in AWS [email protected] This runtime is in addition to the currently supported Node.js 10.x and Node.js 12.x runtimes.

Node.js 14.x, the current Long Term Support (LTS) version of Node.js, uses the new V8 8.1 engine and provides better performance than the previous LTS version, 12.x. In addition, Node.js 14.x supports new features such as nullish coalescing (?? operator), options chaining (?. operator), and diagnostic reporting. For more information about the benefits and new features of Node.js 14.x, read the Node.js 14.x announcement post on the AWS Compute Blog.

To get started with Node.js 14.x, upload your code to AWS Lambda through the AWS CLI or Lambda console, and select Node.js 14.x as the runtime. If you already have existing Node.js functions in Lambda, you can switch to the new runtime by making any required code changes to ensure compatibility with the new runtime and then editing the function configuration to set the runtime to Node.js 14.x.

To learn more about [email protected], visit the product page. For more information about the Node.js programming model in AWS Lambda, read the AWS Lambda Node.js documentation.

Source:: Amazon AWS